If you own an Apple device, you better check to see what model it is right away. Some iPhone and iPad products will turn into rotten Apples if not updated with the correct software before Sunday (November 3).

KSFY TV is reporting, if you own an Apple product from 2012 and earlier, chances are it will require an operating system software update to maintain accurate GPS location and to continue to use functions that rely on correct date and time including App Store, iCloud, email, and web browsing.

Apple recently issued a reminder to customers of older Apple iOS products, so they don't get caught off guard and find themselves unable to access some of the functions available on the device.

According to the KSFY report, if you own any of the Apple devices listed below, it is critical that you do an update immediately:

  • iPhone 5 and iPad (4th generation) Wi-Fi + Cellular should be updated to iOS 10.3.4.
  • iPhone 4s, iPad mini (1st generation) Wi-Fi + Cellular, iPad 2 Wi-Fi + Cellular (CDMA models only), iPad (3rd generation) Wi-Fi + Cellular should be running iOS 9.3.6.

Be advised, Apple says, this issue does not affect iPod touch or any iPad models that have Wi-Fi only. It also will not affect iOS devices newer than those listed above.

If you own an Apple device but are unsure what version it is, here's how to find out:

1. Open the Settings app
2. Tap General, then tap About
3. Look for the number next to Software Version

If an update is required, go to Settings > General, then tap Software Update.

Source: KSFY TV

Sign Up for Our Newsletter

Enter your email to receive the latest news, contests, concert announcements and more directly to your inbox!